SMC 7904WBRA e Vodafone Duplex Casa – Parte III

Bem decidamente o problema deste router com a Vodafone Duplex Casa, é definitivamente o firmware e algo do lado da Vodafone…

Devido a mudanças em casa, tive de passar a usar Wireless no PC em vez de uma ligação por cabo, e claro, montes de problemas… Ligação instável, quedas, etc. etc.  Tudo porque aparentemente o nível de sinal a 54MBPs flutava muito, e então a ligação estava sempre a regulara a velocidade entre os 54MBps e os 2MBps !!!

Desisti, e meti o router a modo B ou seja a 11MBps. Foi da noite para o dia, teve dores de dentes no início, mas agora parece-me estável… De qualquer forma parece-me que a instabilidade também tem a haver com o número de malta para aqui anda com sistemas Wireless. É por isso que vou calçar os patins ao Wireless mas os problemas de segurança associados, e mudar para PLC, pelo menos para o PC de casa.

Em relação à Vodafone, com os problemas de wireless deu mais uma hipótese ao firmware 0.55… Má ideia. Embora não tivesse os problemas que tive quando experimentei anteriormente, este em termos de ligação ADSL perdia o IP de hora em hora !!! ou seja a quando do renew do IP no DHCP da Vodafone. Nem mesmo mantendo tráfego activo o IP mantinha-se ou seja, downloads com mais de uma hora eram todos interrompidos…. O firmware 0.53 não sofre deste problema, ou seja enquanto haja tráfego o IP mantém-se, o que permite que não haja quebras de ligação.

A treta é que aparentemente não há firmwares alternativos para este router, para tentar esmiuçar a coisa, mas enfim, tenho um NSLU2 com firmware Openslug, e vou fazer um script a pingar o server DHCP da vodafone…

Advertisements

SMC 7904 WBRA – Vodafone Duplex – Parte 2

Bem após um largo tempo de espera para ter o Vodafone Duplex, finalmente chegou…

Não tenho nenhum equipamento da Vodafone, somente uso o meu router SMC 7904 WBRA (que ja suporta ADSL2+) que já tem quase três anos, se não mesmo três anos, com o firmware 0.53.

A quando da instalação, o router ligou-se de imediato e tive logo acesso  á internet. Boa atenuação, à roda dos 27 dBs, e um margem de ruído de 6 dBs. Isto é que achei estranho pois tinha anteriormente cerca de 36dBs. Mas aparentemente é mesmo assim. A margem é imposta pelo equipamento da central e controlada dinâmicamente de forma a ter sempre esse valor constante independentemente das  condições da linha. A ver vamos…

Pouco depois começou a tourada…

Aparentemente após a expiração do lease time do DHCP, o router não voltava a ganhar IP, ou seja reportava sempre que não conseguia contactar o servidor DHCP da Vodafone e ficava com 0.0.0.0 … Aparentemente só acontece quando não há actividade, mas é chato ligar o PC e ter de fazer reset ao router para voltar a ter IP. Estranho, então não obtém IP, mas fazendo reset ao router, tinha logo IP…

Aqui coloca-se duas questões: Problemas do router, ou o DHCP da Vodafone só o reconhece depois do link ter caído e voltado a cima… boa questão… Vou supor que é o router, mas o reset com a quebra do link pode despoletar algo do lado da Vodafone, não sei.

Bem, após o reset parece que não há problema algum e tenho IP. Fiz algumas experiências com o MAC do router, mas ao fim de um bocado deixou mesmo de obter qualquer IP. O link UP, mas IP népias. Já estava a ver a minha vida a andar para trás e ter de comprar um router da Vodafone de emergência…

Decidi por uma acção drástica, e fiz reset total e completo ao router… e ficou como tinha saído de fábrica. Configurei todo de início usando o Wizard de configuração e escolhendo o RFC1483 com cliente DHCP, e aparentemente agora está OK. Talvez ainda houvesse resquícios da configuração para o operador anterior e portanto houvesse aqui alguma baralhação…

No entanto prognósticos só no fim do jogo, e vamos ver se é mesmo desta…