[K]Ubuntu: Grub and XP NTLDR missing

My scenario: I have three internal hardisks: 1TB WD (sda) and on 640GB (sdb) WD disks.  sdb is my boot disk, so I have an Windows XP 32bit, and Kubuntu 8.10 ( 🙂 ) 64 bit. I also have an old 160GB ide disk (sdc). I’m running in AHCI mode.

After installing Kubuntu, Grub created entries for Kubuntu and Windows XP.

After reboot I can boot into Kubuntu but booting into Windows XP, it stoped with the dreaded NTLDR is missing…

Kubuntu install created this for booting windows:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdb1
title           Microsoft Windows XP Professional
root            (hd1,0)
savedefault
map            (hd0) (hd1)
map            (hd1) (hd0)
chainloader     +1
Which doesn’t work. At boot it gives the above error: NTLDR is missing.

The solution? In my case all it took was to change to this:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sdb1
title           Microsoft Windows XP Professional
root            (hd1,0)
savedefault
chainloader     +1

Now it boots without any problem

Advertisements

2 thoughts on “[K]Ubuntu: Grub and XP NTLDR missing

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s