Kubuntu 8.04 with ATI drivers hangs on shutdown

This took a lot of time to solve, but I’ve finally found the solution:

What happens:

I’m running Kubuntu 8.04 on a HP nx9420 wich haves an ATI x1600 mobile graphics board.

I was never able to make the fglrx driver and xorg server to assume on boot up the fglrx driver. It always started with the mesa driver, which is OK but too slow for example Google Earth.

The solution on this case was after boot up, on KDE open a root shell and run the command: dpkg-reconfigure -phigh linux-restricted-modules-`uname -r` and then hit CTRL-BACKSPACE.

This was annoying because it means a long boot time until I had a stable system.

Then I installed the envy-ng wich installed the latest ATI drivers. Sundendly the compiz started to work, and everything looked fine, except the shutdown… it hangs with a black screen and the only way to recover was to press the power button for 5/8s.

The solution:

Here it is: http://ubuntuforums.org/showthread.php?t=808543&highlight=ati+shutdown+hang

It works right away. Thanks!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s